phpMyAdmin跨站请求伪造(CVE-2019-12922)

漏洞描述

  phpMyAdmin是一个MySQL和MariaDB数据库的免费开源管理工具,广泛用于管理WordPress、Joomla和许多其他内容管理平台创建的网站的数据库。

  近日,安全研究人员Manuel Garcia Cardenas披露了phpMyAdmin的一个跨站请求伪造(CVE-2019-12922)漏洞。攻击者可利用该漏洞诱使认证用户执行恶意操作。当攻击者将恶意构造的URL发送给目标web管理员时,若该web管理员已使用同一浏览器登陆了phpmyAdmin面板,并打开该链接,即可执行URL包含的恶意请求删除目标服务器上phpMyAdmin面板设置页面中所配置的服务器。

参考链接:

https://packetstormsecurity.com/files/154483/phpMyAdmin-4.9.0.1-Cross-Site-Request-Forgery.html

受影响版本

phpMyAdmin<= 4.9.0.1

临时缓解措施

  官方暂未发布针对此漏洞的修复版本,用户可通过在每次调用时使用token变量验证来对该漏洞进行防护。

  在维护人员对该漏洞进行修复前,强烈建议相关的用户避免点击任何可疑的链接造成风险,请关注官方相关消息,以便及时升级phpMyAdmin至修复版本来防护此漏洞。


发表评论

评论已关闭。

相关文章